Back to overview
Degraded

Issue with Canvas Report Integration - 02/19/2024

Feb 19 at 12:52pm EST

Resolved
Feb 20 at 11:53am EST

Dear Florida Tech Hub Users,

We are pleased to announce that the issue regarding the missing grade information in the Canvas reports has been resolved. Thanks to the collaborative efforts with our Canvas management team, we've implemented measures that address the root cause of the problem and ensure the accuracy and completeness of the data imported into the Florida Tech Hub.

Key Updates:
Extended Timeout: The timeout for generating Canvas reports has been extended to accommodate longer processing times, ensuring all necessary data is included.
Safeguard Implemented: The Florida Tech Hub now has a safeguard in place to discard incomplete reports, preventing potential data integrity issues automatically.
Import Handling Adjusted: We've refined our system to properly handle empty/null values for grades, maintaining the accuracy of student records.

We appreciate your patience and understanding as we worked through this matter. Our commitment to providing a reliable and efficient system remains our top priority, and these updates are a testament to our ongoing efforts to enhance your experience.

Should you encounter any further issues or have any questions, please do not hesitate to contact us at 321-674-6806 or hub@fit.edu.

Thank you for your continued support of the Florida Tech Hub.

Warm regards,

Ce "Samuel" Su, M.S. | The Hub System Admin and Dev
Florida Tech | Student Success and Support Center
321-674-6806
hub@fit.edu

Created
Feb 19 at 12:52pm EST

Issue with Canvas Report Integration - 02/19/2024

Dear Florida Tech Hub Users,

We are currently experiencing a repeat of the issue identified last week, where the Canvas report fails to include current grade information for all students. This problem affects the data accuracy within the Florida Tech Hub, and we understand the inconvenience it may cause to our community.

Current Status:
Issue Identified: Missing grade information in the Canvas report dated 02/19/2024.
Action Taken: We have reached out to the Canvas support team to generate a new report with the complete data set. Our team is actively working on integrating this updated report into the Florida Tech Hub as swiftly as possible.

Impact:
Users may notice discrepancies in grade information within the Florida Tech Hub until this issue is resolved.

Next Steps:
We are closely monitoring the situation and will update the system status once the new report is successfully integrated and the data is verified for accuracy.
We are also in discussions with Canvas to address the root cause of this recurring issue and prevent future occurrences.

We apologize for any inconvenience this may cause and appreciate your patience and understanding as we work to resolve this matter promptly. Our priority is to ensure the reliability and accuracy of the data within the Florida Tech Hub.

For any immediate concerns or assistance, please get in touch with us at 321-674-6806 or hub@fit.edu.

Thank you for your attention to this update and your ongoing support.

Best regards,

The Florida Tech Hub Team