Back to overview
Downtime
The Hub Email Communication is Down
Jan 25 at 03:26am EST
Resolved
Jan 25 at 07:30am EST
According to Microsoft 365 Status Twitter, the outage issue is solved, and now all email communications on The Hub are back to normal.
Affected services
Created
Jan 25 at 03:26am EST
All email function on The Hub is down due to Microsoft Outlook are down, we are waiting for the service back online.
Affected services